home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / net-dialup / lrzsz-0.12.20-r1 / lrzsz-0.12.20-r1.ebuild < prev    next >
Text File  |  2006-05-01  |  1KB  |  47 lines

  1. # Copyright 1999-2006 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/net-dialup/lrzsz/lrzsz-0.12.20-r1.ebuild,v 1.6 2006/03/12 17:00:35 mrness Exp $
  4.  
  5. inherit flag-o-matic eutils
  6.  
  7. DESCRIPTION="Communication package providing the X, Y, and ZMODEM file transfer protocols"
  8. HOMEPAGE="http://www.ohse.de/uwe/software/lrzsz.html"
  9. SRC_URI="http://www.ohse.de/uwe/releases/${P}.tar.gz"
  10.  
  11. LICENSE="GPL-2"
  12. SLOT="0"
  13. KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86"
  14. IUSE="nls"
  15.  
  16. src_unpack() {
  17.     unpack ${A}
  18.  
  19.     epatch "${FILESDIR}/${PN}-makefile-smp.patch"
  20. }
  21.  
  22. src_compile() {
  23.     append-flags -Wstrict-prototypes
  24.     econf $(use_enable nls) || die "econf failed"
  25.     emake || die "emake failed"
  26. }
  27.  
  28. src_test() {
  29.     #Don't use check target. 
  30.     #See bug #120748 before changing this function.
  31.     make vcheck || die "tests failed"
  32. }
  33.  
  34. src_install() {
  35.     make \
  36.         prefix="${D}/usr" \
  37.         mandir="${D}/usr/share/man" \
  38.         install || die "make install failed"
  39.  
  40.     local x
  41.     for x in {r,s}{b,x,z} ; do
  42.         dosym l${x} /usr/bin/${x}
  43.     done
  44.  
  45.     dodoc AUTHORS COMPATABILITY ChangeLog NEWS README* THANKS TODO
  46. }
  47.